System requirements

From Kingdoms and Castles Wiki
Jump to: navigation, search

This article is a stub. You can help Kingdoms and Castles Wiki by expanding it.

The current system requirements for the game Kingdoms and Castles is unknown. As soon as more information is known this page will be updated.

MAC OS X[edit | edit source]

Minimum requirements[edit | edit source]

Maximum requirements[edit | edit source]

Windows[edit | edit source]

Minimum requirements[edit | edit source]

Maximum requirements[edit | edit source]

See also[edit | edit source]